my subscriptions
POPULAR-ALL-RANDOM | LOADING...MORE »
the-packet-thrower commented on a post in r/ccna
1
FantaFriday 3 points

Look up GNS3 or EVE-NG. Will save you the cost of a physical lab and still work great.

the-packet-thrower 2 points

Don’t forget VIRL!

the-packet-thrower 2 points

Uninstall PT, it will have no further value for you :)

the-packet-thrower commented on a post in r/networking
HoorayInternetDrama 3 points

Oh boy, I'm glad there's no search function or very recent threads on the matter

the-packet-thrower 1 point

Pfft how can you monitor on that!

the-packet-thrower commented on a post in r/networking
the-packet-thrower 12 points

The new and upcoming question is just there to gauge your interest in the industry and what fields you follow. There is no wrong answer...though fiber is a pretty weak one on its own IMO.

the-packet-thrower commented on a post in r/ccnp
_chrisjhart 6 points

Static Neighborships

If changing the OSPF network type from NBMA to broadcast doesn’t suit your fancy, we’ll need to configure static OSPF neighbors for each of the PVCs. Keep in mind that OSPF DR/BDR elections occur on NBMA networks as well, so we will need to retain our OSPF priority configuration from our previous adventure with dynamic neighborships.

B1(config)#router ospf 1
B1(config-router)#neighbor 1.1.1.10

#########################

B2(config)#router ospf 1
B2(config-router)#neighbor 1.1.1.10

#########################

B3(config)#router ospf 1
B3(config-router)#neighbor 1.1.1.10

#########################

HQ(config)#router ospf 1
HQ(config-router)#neighbor 1.1.1.1
HQ(config-router)#neighbor 1.1.1.2
HQ(config-router)#neighbor 1.1.1.3

Shortly afterwards, we will see neighborships form on the HQ router.

*Mar 1 14:39:56.524: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.3.1 on Serial1/0 from LOADING to FULL, Loading Done
*Mar 1 14:39:56.528: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.1.1 on Serial1/0 from LOADING to FULL, Loading Done
*Mar 1 14:39:56.532: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.2.1 on Serial1/0 from LOADING to FULL, Loading Done

We can also confirm on our branch routers that routes have been installed, and that the HQ router is the DR.

B1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Serial1/0
 192.168.10.0/32 is subnetted, 1 subnets
O 192.168.10.1 [110/65] via 1.1.1.10, 00:01:39, Serial1/0
C 192.168.1.0/24 is directly connected, Loopback0
 192.168.2.0/32 is subnetted, 1 subnets
O 192.168.2.1 [110/65] via 1.1.1.2, 00:01:39, Serial1/0
 192.168.3.0/32 is subnetted, 1 subnets
O 192.168.3.1 [110/65] via 1.1.1.3, 00:01:39, Serial1/0

B1#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
192.168.10.1 255 FULL/DR 00:01:56 1.1.1.10 Serial1/0

Subinterfaces

Subinterfaces are simply virtual interfaces attached to a physical interface that primarily allow us to overcome split horizon issues that can be encountered when Frame Relay is configured on the physical interface. Frame Relay subinterfaces must be configured in one of two modes: point-to-point, and multipoint. Interestingly enough, the configuration for each mode matches configuration that we’ve already performed on physical interfaces in this lab! Both point-to-point and multipoint subinterfaces utilize the frame-relay interface-dlci [xxx] (where xxx is the DLCI of the link) command and the frame-relay map ip [x.x.x.x] [yyyy] (where x.x.x.x is the Layer 3 IP address, and yyyy is the Layer 2 DLCI) command, depending on whether Layer 3 addresses can be discovered via Inverse ARP or whether Layer 3 addresses must be mapped to specific Layer 2 addresses.

To demonstrate the configuration of each, we are going to set up point-to-point subinterfaces on all three branch routers, then set up three point-to-point subinterfaces on HQ for all three branch routers. In order to do this, we’ll need to change our IP addressing scheme slightly, as a single subnet can only be configured on one interface at a time (within the same VRF, of course.) To make it simple, B1 and HQ will share 1.1.1.0/30, B2 and HQ will share 2.2.2.0/30, and B3 and HQ will share 3.3.3.0/30. We will also need to rip out OSPF and convert back to EIGRP so that split horizon is proven to not be an issue with subinterfaces. The below configuration assumes that IP addresses and Frame Relay configuration (aside from encapsulation frame-relay, of course) were removed from the physical interfaces of all routers.

B1(config)#interface Serial1/0.10 point-to-point
B1(config-subif)#ip address 1.1.1.1 255.255.255.252
B1(config-subif)#frame-relay interface-dlci 110
B1(config)#no router ospf 1
B1(config)#router eigrp 1
B1(config-router)#network 1.1.1.0 0.0.0.3
B1(config-router)#network 192.168.1.0 0.0.0.255

#########################

B2(config)#interface Serial1/0.10 point-to-point
B2(config-subif)#ip address 2.2.2.1 255.255.255.252
B2(config-subif)#frame-relay interface-dlci 210
B2(config)#no router ospf 1
B2(config)#router eigrp 1
B2(config-router)#network 2.2.2.0 0.0.0.3
B2(config-router)#network 192.168.2.0 0.0.0.255

#########################

B3(config)#interface Serial1/0.10 point-to-point
B3(config-subif)#ip address 3.3.3.1 255.255.255.252
B3(config-subif)#frame-relay interface-dlci 310
B3(config)#no router ospf 1
B3(config)#router eigrp 1
B3(config-router)#network 3.3.3.0 0.0.0.3
B3(config-router)#network 192.168.3.0 0.0.0.255

#########################

HQ(config)#interface Serial1/0.10 point-to-point
HQ(config-subif)#ip address 1.1.1.2 255.255.255.252
HQ(config-subif)#frame-relay interface-dlci 101
HQ(config)#interface Serial1/0.20 point-to-point
HQ(config-subif)#ip address 2.2.2.2 255.255.255.252
HQ(config-subif)#frame-relay interface-dlci 102
HQ(config)#interface Serial1/0.30 point-to-point
HQ(config-subif)#ip address 3.3.3.2 255.255.255.252
HQ(config-subif)#frame-relay interface-dlci 103
HQ(config)#no router ospf 1
HQ(config)#router eigrp 1
HQ(config-router)#network 1.1.1.0 0.0.0.3
HQ(config-router)#network 2.2.2.0 0.0.0.3
HQ(config-router)#network 3.3.3.0 0.0.0.3
HQ(config-router)#network 192.168.10.0 0.0.0.255

After some time, all subinterfaces should be up/up and EIGRP should converge. We should also see EIGRP routes in our routing table, despite the fact we have not configured no ip split-horizon eigrp 1 on any of HQ’s interfaces.

HQ#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
 (sec) (ms) Cnt Num
2 3.3.3.1 Se1/0.30 14 00:00:37 988 5000 0 3
1 2.2.2.1 Se1/0.20 11 00:00:40 529 3174 0 3
0 1.1.1.1 Se1/0.10 13 00:00:43 432 2592 0 3
HQ#show ip route eigrp
 1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 1.0.0.0/8 is a summary, 00:00:46, Null0
 2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 2.0.0.0/8 is a summary, 00:00:46, Null0
 3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 3.0.0.0/8 is a summary, 00:00:43, Null0
D 192.168.1.0/24 [90/2297856] via 1.1.1.1, 00:00:47, Serial1/0.10
D 192.168.2.0/24 [90/2297856] via 2.2.2.1, 00:00:44, Serial1/0.20
D 192.168.3.0/24 [90/2297856] via 3.3.3.1, 00:00:41, Serial1/0.30

Conclusion

We’ve explored what Frame Relay is, why it was created, how it works, and some potential issues one could encounter when configuring a routing protocol over a Frame Relay WAN. It is my hope that now that you are armed with this information, you are able to configure and troubleshoot Frame Relay enough to resolve common issues with it in the real world, as well as have the knowledge to logically answer Frame Relay questions that appear on your CCNP ROUTE exam!

I hope this has been helpful!

the-packet-thrower 3 points

Great job

the-packet-thrower commented on a post in r/ccna
7
the-packet-thrower 4 points

This is a good question :)

To understand it you need to ask yourself what an access-list does. All it does it matches traffic but doesn't do anything until it is called by another feature.

E is the right answer because it enables PAT and calls an ACL to match the traffic.

It is worth pointing out that certification exams love to test your reading comprehension and logic. So you should work on thinking through the questions so you don't get caught up on subtle details.

LaCheeserie 2 points

this is so damn frustrating... i feel like i'm ready for the test, sure there are deeper level nitty-gritty stuff that i'll miss, but on something like this... i know the concept, but am throwing questions away because of stuff like this... infuriating.

the-packet-thrower 3 points

Keep in mind that just because you see a question in a practice test it doesn't mean that Cisco will subject you to the same kind of question. Things like boson tend to try to be harder than the actual exam.

the-packet-thrower commented on a post in r/ccna
the-packet-thrower 2 points

The native command on a router is mostly just used to give you better control, if you wanted to move the native (untagged) vlan to another subinterface to make the configuration more clean then you would use the native command. It is considered bad form to have a IP address on the physical interface when you are using subinterfaces.

the-packet-thrower commented on a post in r/ccna
the-packet-thrower 1 point

NAT does the following order of operations / steps

Inside-to-Outside

  • If IPSec then check input access list decryption - for CET (Cisco Encryption Technology) or IPSec

  • check input access list

  • check input rate limits

  • input accounting

  • redirect to web cache

  • policy routing

  • routing

  • NAT inside to outside (local to global translation)

  • crypto (check map and mark for encryption)

  • check output access list

  • inspect (Context-based Access Control (CBAC))

  • TCP intercept

  • encryption

  • Queueing

Outside to Inside

  • IPSec then check input access list

    • decryption - for CET or IPSec
    • check input access list
    • check input rate limits
    • input accounting
    • redirect to web cache
    • NAT outside to inside (global to local translation)
    • policy routing
    • routing
    • crypto (check map and mark for encryption)
    • check output access list
    • inspect CBAC
    • TCP intercept
    • encryption
    • Queueing
the-packet-thrower commented on a post in r/ccna
the-packet-thrower 5 points

You can study with the old book as long as you don't mind failing the exam :)

mufc7777 1 point

why? are there that many differences?

the-packet-thrower 4 points

It would be similar to trying to pass a Windows Server 2016 exam with a Windows 2000 book.

You can read the sticky if you want to see some of the differences.

the-packet-thrower commented on a post in r/ccna
1
the-packet-thrower 1 point

A modem just connects your device to the ISP infrastructure and puts things into the proper encoding for your connection, a cable modem would connect you to the coaxial network and a DSL modem will connect you to the PPPoE/ATM/DSL.

RecursiveNoob 1 point

PC --- SW --- Router --- Modem --- ISP --- Internet?

So, modem is still necessary to be connected to the Internet, right?

the-packet-thrower 1 point

Yup you'll generally need some kind of modem

view more:
next ›

the-packet-thrower

34,318 Karma
2,902 Post Karma
31,416 Comment Karma

Following this user will show all the posts they make to their profile on your front page.

About the-packet-thrower

  • Reddit Birthday

    June 6, 2014

Other Interesting Profiles

    Want to make posts on your
    own profile?

    Sign up to test the Reddit post to profile beta.

    Sign up